Results 1 to 3 of 3

Thread: r6025 pure virtual function call error (maya 64 & mel)

  1. #1
    Sr Environment Artist greuh's Avatar
    Join Date
    Jul 2008
    Location
    Montreal
    Posts
    64

    Default r6025 pure virtual function call error (maya 64 & mel)



    Hi everyone,

    I am playing around with some MEL script and the dragger context, but I can consistently crash maya within seconds while running the script.

    I tried to check my script back to its basics and I can reproduce the problem with the default dragger Context stock example if I specify the draggerContext with the -space "world" attribute.

    Also, I changed the example so it actually creates a locator at the world coordinates returned with the context.
    It seems that it's actually the line that breaks maya, but I have no clue why.

    here is the script (default mel example with the 2 changes I mentionned above)

    // Procedure called on press
    global proc sampleContextPress()
    {
    float $pressPosition[] = `draggerContext -query -anchorPoint sampleContext`;
    print ("Press: " + $pressPosition[0] + " " + $pressPosition[1] + " "
    + $pressPosition[2] + "\n");
    }

    // Procedure called on drag
    global proc sampleContextDrag()
    {
    float $dragPosition[] = `draggerContext -query -dragPoint sampleContext`;
    int $button = `draggerContext -query -button sampleContext`;
    string $modifier = `draggerContext -query -modifier sampleContext`;

    print ("Drag: " + $dragPosition[0] + " " + $dragPosition[1] + " "
    + $dragPosition[2]
    + " Button is " + $button + " Modifier is " + $modifier + "\n");

    spaceLocator -p $dragPosition[0] $dragPosition[1] $dragPosition[2];

    // string $message = ($dragPosition[0] + ", " + $dragPosition[1]);
    // draggerContext -edit -drawString $message sampleContext;
    }

    // Create the dragger context
    draggerContext
    -pressCommand "sampleContextPress"
    -dragCommand "sampleContextDrag"
    -cursor "hand"
    -space "world"
    sampleContext;

    // Set current tool to use the sample context created.
    // Results can be seen by dragging mouse in main window
    setToolTo sampleContext;
    if I run this in the script editor and scrub a viewport some, it will crash maya within moment.

    if I comment out -space "world" it will work fine. if I leave it be but comment the spaceLocator line instead it will work fine also.

    (note: also, I am working with a windows 7 setup, could this have any effect?)
    I would appreciate any help on this matter :)

  2. #2
    Administrator Butters's Avatar
    Join Date
    Aug 2008
    Location
    Vancouver, Canada
    Posts
    249

    Default

    That script is running fine for me on Maya Linux 64. I'll get one of the guys here to give it a run on a windows XP 64 mahcine.

    Have you contacted Autodesk about it? it might be as you say a Windows 7 issue.

    ~B)

  3. #3
    Sr Environment Artist greuh's Avatar
    Join Date
    Jul 2008
    Location
    Montreal
    Posts
    64

    Default

    Thanks for trying it DrBob.

    the error is actually a popup window titled Microsoft Visual C++ something, so that could be why you don't have the issue with linux

    I was working home this week, I'll have to try it on various setup next week when I get back, and eventually log a bug with AD.
    In the meantime, I posted here hoping I was just doing something clearly wrong that could explain this error.

    edit: attached a screenshot of the crash

    also, more often than not, it's the very error window, however occasionally it's the standard maya crash window with the temp timestamp file backup.
    Last edited by greuh; 06-25-2009 at 11:05 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •