[HELP] Adobe 2017 & Eclipse extension builder 3

coding
photoshop
tools

#1

So I just got to know Adobe’s HTML5 extension builder and I am super excited to build some neat tools with it BUT! As I’ve tried to get deep with it, I’ve found out it’s considerably harder to even start a project for 2017’s suite, cause of a myriad of menial reasons.

So I will start explaining what I have faced so far.

1st the CEP folders changed, to this location
(Win User): C:\Users<username>\AppData\Roaming\Adobe\CEP\extensions
(Win System): C:\Program Files (x86)\Common Files\Adobe\CEP\extensions
(Mac User): ∼/Library/Application Support/Adobe/CEP/extensions
(Mac System): /Library/Application Support/Adobe/CEP/extensions/

2nd the enabled version allowed on the default manifest is too low
so we need to change from
Host Name = “PHXS” Version = “[14,0 16.9]”
to
Host Name = “PHXS” Version = “14,0”
(or any defined version range we want)

3rd since extension manager is about to be killed apparently we would need to use the command lines to install our tool

but even knowing those things,
when I try to debug or even just run my panel in Photoshop, it’s not there, Eclipse opens PS normally without any error messages, but on the tab Window>Extensions… my tool’s button it’s just not there!
And when I try to build and install it (with the command lines) it says i got the error -159 and it cannot be installed :confused:

So my fellow programmers with fantastic artistic taste, if you are also interested on this fight would you kindly share with us your discoveries? Thanks!


#2

Oh how silly of me, just came across this


http://davidderaedt.github.io/CC-Extension-Builder-for-Brackets/
It work like a charm, If you’re ever interested in adobe suite tools programming, give a look into this, its awesome!


#3

I have not tried it yet, but I ran across this node library that claims to integrate CEP extension packaging directly into Grunt… https://www.npmjs.com/package/grunt-cep


#4

Any progress with the extensions not visible in Photoshop? I have tried using both Adobe Extension Builder 3 with Eclipse, as well as, Brackets with the CC Extension Builder mentioned above but unfortunately nothing works. I’m working on Photoshop CC 2017 (latest release up until now). Please let me know whether the issue has been resolved and how. Else, is there any other way I can try to plug an extension in Photoshop that doesn’t use any deprecated software?
Thank you in advance!


#5

Hi Mariana. Don’t know if you fix it already? I only know how to fix this is Brackets. You have to manually fix it in Eclipse by navigating to the folder, I think.

Brackets:

Go to CSXS folder and click on manifest.xml. You change the version like so -

<Host Name="PHSP" Version="[16.1,99.9]" />
<Host Name="PHXS" Version="[16.1,99.9]" />

(see the version numbers needs to be changed).

Save.

Launch Photoshop and your extension will now be visible.

Hope this helps.