Issues Exporting Blendshapes from Maya 2016


#1

Our studio recently made the switch from 2015 -> 2016 and all appeared to be well until recently when I noticed about half of our skinned mesh props that featured blendshapes were failing to export with intact blendshape data. When imported into UE4 it recognizes the Morph Target node name and influences, but 0 verticies. Similarly, if I reimport the exported FBX it seems the Blendshape node and names, but if you increase the weights the mesh is unaffected.

In the past this has happened when the Blendshape targets weren’t included in the the export set. However I’ve checked and the targets are definitely included in the export selection.

Initially I made some progress when I tested moving the location of the blendshape targets. In some rigs I include the mesh in the target rig, and in others I included it in the character file. I had 2 files that weren’t exporting from blendshapes from 2016 (despite previously working in 2015) start working when I moved them to the rig file. I thought I had it solved, and that there was an issue with the data coming from a non-file reference (not sure why that would be, but its an easy enough fix) but now I’ve encountered a new prop file that did not return to working even after moving the blendshapes.

The pipeline here at the studio is to keep the mesh and rig in seperate files, then reference those 2 files in and skin only in a character file. Then that character file is referenced into animation files. That way I can skin many meshes to the same rig and replace reference to preview different characters all in maya. This means that the blendshapes are often created in the character file for ease of use.

Does anyone have an ideas what might be going on with 2016? We use the same scripts for export and the same files used to work in 2015. Did anything change in the python fbx settings api (since they added the new game export window that we aren’t using)?

I’m currently stumped and as we many page and book based props that have extra blendshapes for detail deformations we’ve got work backing up that I can’t export.

Thanks for reading, and I’d love to hear from any other 2015 -> 2016 converts that encountered any other problems. Besides this its been smooth sailing for us, the file profiling is great.


#2

Hi Saveremreve,
I have yet to move our team to 2016 but I fear the same will be true for us as well. Have you tried changing the actual export settings in FBX to a different version, such as 2015, 2014? It unders FBX Export > Advanced Options > FBX File Format. This is not ideal and doesn’t necessarily fix the issue but it could get around the problem with the same result. Have you opened the raw FBX files in Maya, Max or Mobu to see if the blendshapes exist and there isn’t an import issue with UE4 and the latest FBX sdk?


#3

Delete post not an option.


#4

Hey, yeah in case it wasn’t clear there I confirmed similar results both from UE4 and maya import - the blendshape node and the target names are visible, but no deformation occurs when the weights are changed. I have tried rolling back to the previous versions and its all the same problem. Are there any basic best practices that I’ve been missing? Generally speaking I keep the target mesh around - I don’t like the delete targets option. I heard on some forums that adding a key on the weight properties can help, but it didn’t. We’re had trouble with Mentral Ray putting in nodes we don’t use and plug-ins failing to load that cause our files to open with errors and now many of them are stuck in binary mode. Some of them we made changes to and now I can’t open them in 2015 to just get around this problem. Thanks for the help.


#5

Barring any odd plugins you should be able to open in 2015. If you can’t disable them in 2016, you should be able to save as .ma ASCII format and do some hand editing of deleting plugin lines and or connections. Also, I think you can save without including plugin details and ignore plugin details on open. You may have issues saving as Maya ASCII with unknown nodes, but you will need to track them down and delete them from the scene or use the Optimize scene option to remove them.

There are no best practices short of basic naming conventions for the blendshapes. Ive seen where some names weren’t suitable in the past but that should have been addressed by now. I’ll try opening and exporting one of my scenes from 2016 tomorrow and see what happens.


#6

I tried this with varying results in 2016/2016.5 but in all cases my skinned mesh and blendshapes are in a singular base file with no references. Most issues are down to exporting selected with everything necessary, skinned mesh, joints, and blendshape target meshes. Having FBX options checked to include connections will generally help this but it is always better to be very inclusive with your selections.


#7

A bit of thread necromancy - but the troubling resolution to this issue was to restart my machine. Somehow after running all day at some point any instance of Maya opened would no longer reliably produce skeletal meshes or blendshape data. I’ve moved on to other work but I’m going to take time to clean up this export code and try to ensure that no transient setting would affect the export. Has anyone else experience this with Maya?